Unplanned downtime due to system maintenance
Incident Report for MCBlockBuilds.Net
Resolved
This incident has been resolved.
Posted Aug 19, 2021 - 21:13 UTC
Identified
We are looking into an issue with ram and should be back soon.
Posted Aug 19, 2021 - 17:41 UTC
This incident affected: Minecraft Server.