Unplanned downtime due to storage issue
Incident Report for MCBlockBuilds.Net
Resolved
This incident has been resolved.
Posted Jun 24, 2021 - 23:59 UTC
Update
We have fixed the issue.
Posted Jun 24, 2021 - 23:58 UTC
Update
We are working on a fix
Posted Jun 24, 2021 - 23:52 UTC
Investigating
We are currently investigating this issue.
Posted Jun 24, 2021 - 23:51 UTC
This incident affected: Minecraft Server and Website.